Процедура ТоварыПриАктивизацииСтроки(Элемент) 



Министерство образования Российской Федерации

 

Государственное образовательное учреждение высшего профессионального образования

 

Владимирский государственный университет им. Александра Григорьевича и Николая Григорьевича Столетовых

 

Кафедра информационных систем и информационного менеджмента

 

 

Лабораторная работа №2

 

По дисциплине «Корпоративные ИС»

 

 

Выполнил: студент гр. ИСГ-108

    Гребенюк Кирилл Валерьевич

 

       Принял:

        Горьков Илья Михайлович

 

Владимир 2011

 

Оперативный учёт

Целью данной лабораторной работы было создать документ расходная накладная, в котором бы фиксировался факт продажи товаров покупателям. По своей структуре данный документ полностью аналогичен документу «Приходная накладная».

Расходная накладная

В конфигурации для приходной накладной присутствуют:

- Подсистемы

- Учёт торговых операций

- Бухгалтерский учёт

- Учет заработной платы и кадры

- Общие модули

- Основной (содержит процедуру «РассчитатьСумму»)

- Константы

- Наименование компании

- Дата регистрации компании

- Справочники

- Организации

- Реквезиты:

- Префикс(строка,3,переменная)

- Подразделения

- Дети

- Контрагенты

- Сотрудники

- Реквезиты:

- Дата Рождения(дата)

- Табличные части:

- Образование

- УчебноеЗаведение(строка,100,переменная)

- ДатаПриема (дата)

- ДатаОкончания(дата)

- Примечание (строка,100,переменная)

- Должности

- Валюты

- Реквезиты:

- НаименованиеПолное(строка,50,переменная)

- Номенклатура

- Реквезиты:

- Товары(строка,20,переменная)

- Цена(строка,10,переменная)

- Документ

- Приходная накладная

- Реквизиты:

- Организация (СправочникСсылка.Организации)

- Контрагент (СправочникСсылка.Контрагенты)

- Сотрудник (СправочникСсылка.Сотрудники)

- Сумма Документа (число,12,2,неотриц.)

- Табличные части

- Товары

- Номенклатура (СправочникСсылка.Номенклатура)

- Количество (число,10,0,неотриц.)

- Цена (число,10,2,неотриц.)

- Сумма (число,12,2)

- Расходная накладная

- Реквизиты:

- Организация (СправочникСсылка.Организации)

- Контрагент (СправочникСсылка.Контрагенты)

- Сотрудник (СправочникСсылка.Сотрудники)

- Сумма Документа (число,12,2,неотриц.)

- Получение Остатков На Форме (число,1,0,неотриц.)

- Табличные части

- Товары

- Номенклатура (СправочникСсылка.Номенклатура)

- Количество (число,10,0,неотриц.)

- Цена (число,10,2,неотриц.)

- Сумма (число,12,2)

- Регистр сведений

- Сведения о сотрудниках

- Изменения

- Сотрудник (СправочникСсылка.Сотрудники)

- Ресурсы

- Подразделения (СправочникСсылка.Подразделения)

- Должность (СправочникСсылка.Должности)

- Оклад (число,10,2,неотриц.)

- Курсы валют

- Изменения

- Валюта (СправочникСсылка.Валюты)

- Ресурсы

- Курс (число,10,2,неотриц.)

- Цены поставщиков

- Изменения

- Поставщик (СправочникСсылка.Контрагенты)

- Номенклатура (СправочникСсылка.Номенклатура)

- Ресурсы

- Цена (число,10,2,неотриц.)

- Регистр накопления

- Остатки номенклатуры

- Изменения

- Номенклатура (СправочникСсылка.Номенклатура)

- Ресурсы

- Количество (число,10,0,неотриц.)

- Сумма (число,12,2)

 

 

Для документа создана специальная форма ввода данных.

Модуль объекта документа «Приходная накладная»:

 

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

       ТабЧасть =ЭлементыФормы.Товары.ТекущиеДанные; 

       ТабЧасть.Сумма = ТабЧасть.Цена * ТабЧасть.Количество;

       СуммаДокумента=Товары.Итог("Сумма");

КонецПроцедуры

 

Процедура ПриОткрытии()

Если ЭтоНовый() Тогда

ПолучениеОстатковНаФорме = 2;

ПолучениеОстатковВмодуле = 1;

Иначе

ПолучениеОстатковНаФорме = 0;

ПолучениеОстатковВмодуле = 0;

КонецЕсли;    

КонецПроцедуры

 

Процедура ТоварыПриАктивизацииСтроки(Элемент) 

Если ПолучениеОстатковНаФорме = 0 Тогда

Если ЭтоНовый() Тогда

Сообщить("Остатки получить не могу. Документ не записан!");

Возврат;

Иначе 

ГраницаПолученияОстатков = МоментВремени();

КонецЕсли;

ИначеЕсли ПолучениеОстатковНаФорме = 1 Тогда

Если ЭтоНовый() Тогда

Сообщить("Остатки получить не могу. Документ не записан!");

Возврат;

Иначе 

МоментПолученияОстатков = Новый МоментВремени(Дата, Ссылка);

ГраницаПолученияОстатков = Новый Граница(МоментПолученияОстатков, ВидГраницы.Включая);

КонецЕсли;

Иначе

ГраницаПолученияОстатков=КонецДня(Дата);

КонецЕсли;

 

ФильтрПоРегистру = Новый Структура("Номенклатура");

ФильтрПоРегистру.Номенклатура = ЭлементыФормы.Товары.ТекущиеДанные.Номенклатура;

 

ТаблицаОстатков =

РегистрыНакопления.ОстаткиНоменлатуры.Остатки(ГраницаПолученияОстатков,ФильтрПоРегистру,,"Количество");

ЭлементыФормы.Надпись1.Заголовок = "Остаток: "+ТаблицаОстатков.Итог("Количество");

 

КонецПроцедуры

 


Дата добавления: 2018-02-15; просмотров: 200; ЗАКАЗАТЬ РАБОТУ